Etherchannel / Bonding / Port-channel – Network Redundancy for Servers


Etherchannel, Portchannel, bonding or NIC teaming?

Etherchannel, portchannel, bonding, link-aggregation and NIC teaming are all terms to describe the bundling of two or more ports to form one logical Ethernet link. Ether-channel/Port-channel is the term used by Cisco convention and is an open standard known as IEEE 802.3ad (LACP – Link aggregation Control Protocol). As such most devices and systems that utilize Ethernet links are compatible with this standard.

There are two main advantages of creating such bonds. One of them being able to increase the throughput by combining the bandwidth of the individual ports. The other is increase in network reliability as a coupled Ethernet link is able to survive individual link failures. However, there are limitations to this as the bundled ports needs to reside on the same switch which causes the switch to be a single point of failure. To overcome this scenario, Cisco switches are stacked to form one logical switch so that ports from the bundle can be evenly distributed across the switches to mitigate effects of a single switch failure.

Cisco Switch Configuration

Below are the configurations in the Cisco switch to create an ether-channel across two ports:

First define the ether-channel load balancing algorithm used:

Under Global configuration mode define the load balancing algorithm:

port-channel load-balance src-dst-ip

Source/destination IP hashing is most suitable for our use as we are able to get a more even distribution of packets unlike Src/dst MAC address hashing, routed packets that enter the same appears as the same mac address which causes the packets to go through one link.

In order to create a bonded link, each interface of the bond will need to be setup with the identical configuration. I recommend using the RANGE command in Cisco IOS to configure multiple interfaces simultaneously.

Under global configuration mode enter:

interface range GigabitEthernet 1/0/14,  GigabitEthernet 2/0/14

Then enter the following:

description SERVER1
switchport access vlan 256 
switchport mode access 
channel-protocol lacp 
channel-group 14 mode active 
spanning-tree portfast

The above snippet will create an ether-channel using ports gi1/0/14 and gi1/0/14 and form a logical interface named Port-channel 14 (Po14). The 3750G Cisco switches support up to 48 ether-channels of up to 8 ports per channel.

The channel group number can be any number from 1-48 but in order to keep a consistent naming convention a group number that matches the port assigned is used.

Once the ports have been configured a Port channel logical interface will be automatically created.

Enter the same configuration in the port channel interface configuration mode without the channel-group and the channel-protocol commands:

interface Port-channel14 
description SERVER1
switchport access vlan 256
switchport mode access
spanning-tree portfast

In order to verify if the configuration is correct, enter the following to view the ports that have been assigned to the port-channel

sh etherchannel summary

and

sh etherchannel port-channel
Related Posts with Thumbnails

About the Author

Alfred Tong
Author and owner of this blog. A Networking enthusiast, full time networking and systems Engineer. Generally curious about all things IT.Certifications: GIAC GSEC, CCNP-S, CCNP, CCSP, CCDP, CCNA, RHCE, JNCIA - FWV